AWS Service Outage Affecting Virtual Lab

Incident Report for Dickinson

Resolved

Amazon seems to have completed repairs of their systems.
Posted May 08, 2026 - 13:25 EDT

Monitoring

Posted May 08, 2026 - 12:08 EDT

Identified

Amazon Web Services which hosts the Virtual Lab is experiencing service outages. Propeller has let us know they will provide updates as they receive them from Amazon.
Posted May 08, 2026 - 11:26 EDT
This incident affected: Dickinson Virtual Lab (Propeller).