Amazon Web Services Outage Affecting Cloud-Hosted Services

Incident Report for Dickinson

Resolved

Amazon reports most services have been restored and things are returning to operational status.
Posted Oct 20, 2025 - 16:25 EDT

Monitoring

Amazon connection issues continue. Here is their service health updates page:

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:23 EDT

Identified

Amazon Web Services (AWS) is currently experiencing a widespread outage that is affecting many cloud-based systems across the internet. As a result, some Dickinson services that rely on AWS—such as Brightspace, Propeller (the Virtual Lab), Adobe, and others—may be slow to load or produce intermittent errors.
Posted Oct 20, 2025 - 09:48 EDT