Workday Connectivity Issue

Incident Report for Dickinson

Resolved

Update from Workday to tenants:

At 11:25 AM PT, our service provider resolved the issue that was disrupting access to Workday for some customers. Customers who were experiencing issues should now be able to successfully access the Workday service. Given that service has been restored, the webinar is cancelled.

We are conducting a root cause analysis, which we’ll make available to our customers within 10 business days.

We understand the mission critical nature of our service in supporting your business and sincerely apologize for the challenges this has caused.
Posted Feb 20, 2026 - 14:57 EST

Monitoring

Update from Workday to tenants:

On February 20 at 9:56 am PT, we began experiencing a service disruption impacting access to all of our data centers. This is not an issue with Workday’s services, which remain fully operational. Your data remains secure and unaffected. However, a widespread disruption affecting major Internet Service Providers (ISPs) and network routes is currently impacting global internet traffic and disrupting access to Workday for some customers. Impacts may vary by region. Some users may experience slow performance or timeouts depending on their local internet routing.
Posted Feb 20, 2026 - 14:35 EST

Identified

Workday is experiencing issues with the datacenter which houses the Dickinson tenant. They are aware and are working to resolve the issue.
Posted Feb 20, 2026 - 13:37 EST
This incident affected: Workday.