Dickinson's Internet Provider is Experiencing Issues
Incident Report for Dickinson
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 19:46 EDT
Update
We are continuing to investigate this issue.
Posted Apr 27, 2023 - 19:45 EDT
Update
We are continuing to investigate this issue.
Posted Apr 27, 2023 - 15:30 EDT
Investigating
The internet provider Dickinson uses is currently experiencing trouble. This may affect campus users from getting to non-Dickinson internet resources and/or users accessing Dickinson services from off-campus. ITS is investigating the situation. Thank you for your patience.
Posted Apr 27, 2023 - 15:28 EDT
This incident affected: Banner Self-Service (Employee Self-Service, Banner General Self-Service, Student Course Registration, Faculty Self Service, Finance Self-Service, Student Self-Service) and Dickinson's Internet Connection, Dickinson Website (www.dickinson.edu), Single Sign-On/Authentication, Gateway, Moodle, Banner Admin, Cognos, CLIQ, Degree Works, Zoom Web Client.