Brightspace Experiencing Issues

Incident Report for Dickinson

Resolved

This incident has been resolved.
Posted Dec 20, 2025 - 12:17 EST

Identified

ITS is aware of an issue affecting Brightspace and is actively working toward a resolution.
Posted Dec 20, 2025 - 11:13 EST
This incident affected: Brightspace.