Dickinson's Internet Provider is Experiencing Issues
Incident Report for Dickinson
Update
We are continuing to monitor for any further issues.
Posted Jun 15, 2024 - 14:31 EDT
Update
Service restored
Posted Jun 14, 2024 - 18:56 EDT
Update
Dickinson's internet service provider has informed us that fiberoptic lines were damaged near Philadelphia and they are working on the issue. They are still unable to provide a restoration estimate at this time.
Posted Jun 14, 2024 - 15:23 EDT
Monitoring
Dickinson's internet service provider has identified an issue near Philadelphia as the cause for the outage but could not provide an estimated time for restoration of services just yet.
Posted Jun 14, 2024 - 12:46 EDT
Update
The internet provider Dickinson uses is currently experiencing trouble. This may affect campus users from getting to non-Dickinson internet resources and/or users accessing Dickinson services from off-campus. ITS is monitoring the situation. Thank you for your patience.
Posted Jun 14, 2024 - 09:34 EDT
Identified
The internet provider Dickinson uses is currently experiencing trouble. This may affect campus users from getting to non-Dickinson internet resources and/or users accessing Dickinson services from off-campus. ITS is monitoring the situation. Thank you for your patience.
Posted Jun 14, 2024 - 09:23 EDT
This incident affects: Banner Self-Service (Employee Self-Service, Banner General Self-Service, Student Course Registration, Faculty Self Service, Finance Self-Service, Student Self-Service) and Dickinson's Internet Connection, Dickinson Website (www.dickinson.edu), Single Sign-On/Authentication, Gateway, Moodle, Banner Admin, Cognos, CLIQ, Degree Works, Zoom Web Client.