Help Desk Phone System (Aircall) Down
Incident Report for Dickinson
Postmortem

AirCall is a cloud-based service for handling calls to and from the ITS Help Desk. AirCall’s internet provider was down, thus AirCall was not online. Their service provide regained service.

Posted Oct 13, 2023 - 13:22 EDT

Resolved
AirCall has regained internet access and Help Desk phone calling is restored.
Posted Oct 12, 2023 - 13:15 EDT
Monitoring
Aircall, Dickinson cloud phone service for the Help Desk, is experiencing issues with their internet provider. Users may still report technical issues to helpdesk@dickinson.edu.

https://statusgator.com/services/aircall
Posted Oct 12, 2023 - 10:53 EDT
This incident affected: Help Desk Phone System.