Campus Internet Connectivity
Incident Report for Dickinson
Postmortem

Campus internet service was disrupted around 3PM Wednesday, March 21st. The college’s service provider, Lumen, reported that a tree in the Camp Hill/Mechanicsburg area knocked out power and fiber optic services and resulted in a brush fire that had to be cleared before repairs to the cable could be completed. Service was restored shortly after noon on Thursday, March 21st.

Posted Mar 21, 2024 - 13:04 EDT

Resolved
Dickinson’s internet service provider has repaired the broken lines and service has been restored to campus.
Posted Mar 21, 2024 - 13:01 EDT
Update
Service restored
Posted Mar 21, 2024 - 12:56 EDT
Update
Service restored
Posted Mar 21, 2024 - 11:40 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 21, 2024 - 11:39 EDT
Update
Latest update from our provider: Splicing efforts are in progress, and the Local Provider has not yet provided an estimated completion time. We will provide more information once the estimated time is provided or as new information comes in.
Posted Mar 21, 2024 - 11:38 EDT
Update
Latest update from our provider: Splicing efforts are in progress, and the Local Provider has not yet provided an estimated completion time. We will provide more information once the estimated time is provided or as new information comes in.
Posted Mar 21, 2024 - 09:20 EDT
Update
Latest update from our provider: Splicing efforts are in progress, and the Local Provider has not yet provided an estimated completion time. We will provide more information once the estimated time is provided or as new information comes in.
Posted Mar 21, 2024 - 08:58 EDT
Monitoring
Campus internet service remains unavailable. At this time, our internet service provider, Lumen, cannot provide an estimated time for when services will be restored. We will continue to update this page when we have additional information.

Since yesterday, we have learned additional details regarding the incident from Lumen. Campus internet service was disrupted around 3:00 yesterday afternoon. The college’s service provider, Lumen, reported that a tree in Mechanicsburg knocked out power and fiber optic service to the area. The power outage resulted in a brush fire that had to be cleared before diagnostics to the damaged cable could be completed.

Lumen has been working throughout the night to replace and splice the fiber optic cable that was damaged. We do not have an estimate on when internet will be restored, but we will keep the campus updated.
Posted Mar 21, 2024 - 07:44 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 20, 2024 - 18:49 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 20, 2024 - 18:48 EDT
Identified
Dickinson’s internet provider is experiencing issues in our area.
Posted Mar 20, 2024 - 15:34 EDT
Investigating
Dickinson’s connection to the internet is experiencing issues. We are investigating.
Posted Mar 20, 2024 - 15:21 EDT
This incident affected: Dickinson's Internet Connection, Campus WiFi, Dickinson Website (www.dickinson.edu), Single Sign-On/Authentication, Gateway, Help Desk Phone System, Moodle, Banner Admin, and Banner Communication Manager.